User Rating: 4 / 5

Star ActiveStar ActiveStar ActiveStar ActiveStar Inactive
 

Article Index

Install Joomla! 1.5

At last we come to the purpose of this guide. The installation of joomla15 package for FreeBSD will automatically fetches and installs any dependent packages. However, one of the required packages, pdflib, doesn't exist on the FreeBSD package repository. You will have to compile and install it from the portage before you proceed to install joomla15 package.

# cd /usr/ports/print/pdflib
# make install
# make clean

Albeit the joomla15 package contains Joomla! 1.5.18 which is an outdated version, we will use it to bring in all the dependencies, and later update it to the most recent version.

# pkg_add -r joomla15

You will see a long list of packages get installed due to dependencies.

To download the latest version of Joomla! 1.5, you can visit http://www.joomla.org/download.html and find and fetch the latest version of the file format you want. For instance,

# fetch http://joomlacode.org/gf/download/frsrelease/12610/53419/Joomla_1.5.20-Stable-Full_Package.tar.bz2

We then remove all the files in the directory /usr/local/www/joomla15, which are installed by joomla15 package, and replace them with files from the latest Joomla! 1.5 version.

# rm -rf /usr/local/www/joomla15/*
# cd /usr/local/www/joomla15
# tar -jxvf /<your download folder>/Joomla_1.5.20-Stable-Full_Package.tar.bz2

Please substitute the filename of the version you downloaded for the one in the last command.

Let's adjust the owner and permission of those files.

chown -R www:www *
chmod -R o-rwx *
FaLang translation system by Faboba