会员评分: 4 / 5

点亮的星星点亮的星星点亮的星星点亮的星星灰暗的星星
 

目 录

安装 Joomla! 1.5

终于我们来到这篇指南的真正目的。安装 FreeBSD 的 joomla15 套件包之过程中,将会自动抓取并且安装任何所依赖的套件包。然而,有一件需要的套件 — pdflib,并不存在于 FreeBSD 的套件库内。你必须在安装 joomla15 套件之前,由 portage 中编译与安装它。

# cd /usr/ports/print/pdflib
# make install
# make clean

虽然 joomla15 套件包内的 Joomla! 1.5.18 试过时的版本,我们还是将用它来带进全部所依赖的套件,之后再更新到最新的版本。

# pkg_add -r joomla15

你会看到一长列的套件被安装进来,那些都是所依赖的套件。

要下载最新版的 Joomla! 1.5,你可照访 http://www.joomla.org/download.html 来寻找和取得你所用的档案格式。例如:

# fetch http://joomlacode.org/gf/download/frsrelease/12610/53419/Joomla_1.5.20-Stable-Full_Package.tar.bz2

然后我们把 /usr/local/www/joomla15 目录中,所有 joomla15 套件安装进来的档案移除,用最新的 Joomla! 1.5 版本里的档案来取代。

# rm -rf /usr/local/www/joomla15/*
# cd /usr/local/www/joomla15
# tar -jxvf /<your download folder>/Joomla_1.5.20-Stable-Full_Package.tar.bz2

请在最后的指令中,将版本的档名以你所下载的档案之名称来替代。

现在让我们调整那些档案的拥有者和权限。

chown -R www:www *
chmod -R o-rwx *

FaLang translation system by Faboba