会员评分: 4 / 5

点亮的星星点亮的星星点亮的星星点亮的星星灰暗的星星

Joom!Fish 2.1.x 已经释出给 Joom!Fish 俱乐部的会员有一阵子了。终于现在公开释出版到来了。于 2010 年 11 月 24 日,官方网站宣布了 Joom!Fish 2.1.5

这个版本除了修补各样的问题外,也提供对 PHP 5.3 及目前 Joomla! 1.5.x 版更佳的相容性。释出的档案可于新的下载网页上找到。如果对此版本遇到问题,或想提出回馈,你可以贴一封文章在它的专属论坛


会员评分: 4 / 5

点亮的星星点亮的星星点亮的星星点亮的星星灰暗的星星

今天(十月二十七日) Joom!Fish 推出了 2.0.4 版。此版本包括了数个臭虫修补以及一项安全修正。这个安全修正式与在语言切换模组内发现的 XSS 缺失有关。如果您目前使用 Joom!Fish 的任何先前版本,请尽早做更新。

正体中文的使用者可能会高兴看到台湾的国旗现在已经被包含于 Joom!Fish 的官方版中。当您在为您的 Joom!Fish 安装设置语言时,您只要在简码栏内填入 tw,就可使用台湾国旗用在语言选择。

跟随着这份 Joom!Fish 2.0.4 的释出,对 PHP 4.x 的支援也将不再着重。从下一版 - Joom!Fish 2.1 - 开始,将只支援 PHP 5.0 及以上的版本,并加入一些 PHP 5.3 的功能。如果您还在使用 PHP 4.x,请好好地考虑升级吧!

Joom!Fish 团队提供了一份完整套件包和三份升级补缀包。做新的安装时,当然是用完整套件包。但要升级先前的版本,您可以选择先解除安装,然后用完整套件包重新安装;或者是直接把正确的升级包解压缩到您的 Joomla! 安装里。

全部这些包装都可在 Joom!Fish 的下载网页下载。

 

会员评分: 5 / 5

点亮的星星点亮的星星点亮的星星点亮的星星点亮的星星

Joom!Fish 团队已经运行一个展示网站有一阵子了,它展现一个预设的 Joomla! 安装,提供多种语言可用。最早当它开始上线运作时,只包含有三种语言。之后,语言的总数增加到五个。它们全部都是西方语言。

为了要增高使用 Joom!Fish 作为多语言(包括正体中文)方案的知名度,我们决定将 sample_data.sql 翻译成正体中文给展示网站使用。经过几天的翻译工作,我们很高兴地把完整的 sample_data.sql 翻译提交给 Joom!Fish 团队。

于七月三十一日,Joom!Fish 团队把正体中文加入了他们的展示网站。现在你可以造访 demo.joomfish.net 来看看一个有七种语言的多语言网站。

请注意目前该展示网站使用中国国旗来代表正体中文。我们正在和 Joom!Fish 团队商量,把它改成用中华民国国旗来代表。我们鼓励中国的 Joomla! 使用者,提交 sample_data.sql 的简体中文翻译,如此我们能在展示网站上两种中文都有。

 

灰暗的星星灰暗的星星灰暗的星星灰暗的星星灰暗的星星

Joom!Fish 开发团队于周末(六月二十二日),通知了它的俱乐部会员,Joom!Fish 2.1 的第一个抢鲜版已经可以下载。这一版本包括了几项臭虫修补,以及一些功能使额外的扩充套件更为有效率。

在最后的正式版推出之前,预期还会有另一个抢鲜版。Joom!Fish 2.1 正式版将并入一些经由回馈系统提出的功能要求,并且也会将语言档做重大的清理。

如果你是 Joom!Fish 俱乐部的会员,欢迎你前往俱乐部下载网页,取得这个抢鲜版。此版本被 Joom!Fish 开发人员认为足够稳定,但在升级之前还请先做备份。

请将任何关于这个抢鲜版的臭虫或问题,报告到 Joom!Fish 支援论坛

 

会员评分: 4 / 5

点亮的星星点亮的星星点亮的星星点亮的星星灰暗的星星

紧跟 Joomla! 1.5.10 的推出,Joom!Fish 专案宣布了 Joom!Fish 2.0.3。这个版本包含了臭虫修补及功能增进,还设法避过 Joomla! 1.5.10 中安装程式的臭虫。

以下是 Joom!Fish 2.0.3 里的变更大略,是从官方宣布直接截取而来:

  • 避过 Joomla! 1.5.10 中安装程式的臭虫
  • 允许翻译选单别名
  • 增加新的选项,使得翻译时在拉下选单里可以隐藏预设语言
  • 于建立资料表之前,先检查资料库的文字校对功能
  • 修正在删除孤儿翻译和删除语言时会有的问题
  • 新的乔治亚国旗

此新版可于 Joom!Fish 专案的下载网页下载。那个压缩的安装档案能够用来做新的安装及升级安装。他们也计划推出修补档,给在伺服器上做直接的档案取代来升级。

Joom!Fish 专案也再度提醒大家,Joom!Fish 2.0.3 必须在 PHP 5 下使用。并没有在 PHP 4 下做过任何测试。

FaLang translation system by Faboba